bom(5) BSD File Formats Manual bom(5)
bom -- bill of materials
The Mac OS X Installer uses a file system "bill of materials" to deter- mine which files to install, remove, or upgrade. A bill of materials, bom, contains all the files within a directory, along with some informa- tion about each file. File information includes: the file's UNIX permis- sions, its owner and group, its size, its time of last modification, and so on. Also included are a checksum of each file and information about hard links. The bill of materials for installed packages are found within the package receipts located in /Library/Receipts.
Mac OS X's bill of materials format is not compatible with formats from older operating systems.
The bill of materials file appeared in NeXTSTEP to support installation. The file format was updated and extended for Mac OS X 10.0. The format was extended to support 64 bit file sizes with OS X 10.3. Mac OS X 28 September 2006 Mac OS X
Mac OS X 10.6 - Generated Thu Sep 17 20:25:03 CDT 2009