sync(8) BSD System Manager's Manual sync(8)
sync -- force completion of pending disk writes (flush cache)
The sync utility can be called to ensure that all disk writes have been completed before the processor is halted in a way not suitably done by shutdown(8). Generally, it is preferable to use shutdown(8) to shut down the system, as they may perform additional actions such as resynchroniz- ing the hardware clock and flushing internal caches before performing a final sync. The sync utility utilizes the sync(2) function call.
A sync utility appeared in Version 4 AT&T UNIX. BSD May 31, 1993 BSD
Mac OS X 10.8 - Generated Tue Sep 4 11:23:01 CDT 2012