pstat(8) BSD System Manager's Manual pstat(8)
pstat - display system data structures
pstat [-Tfnstv] [-M core] [-N system]
Pstat displays open file entry, swap space utilization, terminal state, and vnode data structures. If corefile is given, the information is sought there, otherwise in /dev/kmem. The required namelist is taken from /vmunix unless system is specified. The -n option specifies that devices should be printed out by major/minor number rather than by name. Options are -T Prints the number of used and free slots in the several system tables and is useful for checking to see how large system tables have become if the system is under heavy load. -f Print the open file table with these headings: LOC The core location of this table entry. TYPE The type of object the file table entry points to. FLG Miscellaneous state variables encoded thus: R open for reading W open for writing A open for appending S shared lock present X exclusive lock present I signal pgrp when data ready CNT Number of processes that know this open file. MSG Number of messages outstanding for this file. DATA The location of the vnode table entry or socket structure for this file. OFFSET The file offset (see lseek(2)). -s Print information about swap space usage on all the swap areas compiled into the kernel. The first column is the device name of the partition. The next column is the total space available in the partition. The Used column indicates the total blocks used so far; the Available column indicates how much space is remain- ing on each partition. The Capacity reports the percentage of space used. If more than one partition is configured into the system, totals for all of the statistics will be reported in the final line of the report. -t Print table for terminals with these headings: RAW Number of characters in raw input queue. CAN Number of characters in canonicalized input queue. OUT Number of characters in output queue. MODE See tty(4). ADDR Physical device address. DEL Number of delimiters (newlines) in canonicalized input queue. COL Calculated column position of terminal. STATE Miscellaneous state variables encoded thus: T delay timeout in progress W waiting for open to complete O open F outq has been flushed during DMA C carrier is on B busy doing output A process is awaiting output X open for exclusive use S output stopped H hangup on close PGRP Process group for which this is controlling terminal. DISC Line discipline; blank is old tty OTTYDISC or `new tty' for NTTYDISC or `net' for NETLDISC (see bk(4)). -v Print the active vnodes. Each group of vnodes corresponding to a particular filesystem is preceded by a two line header. The first line consists of the following: *** MOUNT fstype from on on fsflags where fstype is one of ufs, nfs, mfs, or pc; from is the filesys- tem is mounted from; on is the directory the filesystem is mounted on; and fsflags is a list of optional flags applied to the mount (see mount(8)). the first part of which are fixed, and the second part are filesystem type specific. The headers common to all vnodes are: ADDR Location of this vnode. TYP File type. VFLAG A list of letters representing vnode flags: R - VROOT T - VTEXT L - VXLOCK W - VXWANT E - VEXLOCK S - VSHLOCK T - VLWAIT A - VALIASED B - VBWAIT USE The number of references to this vnode. HOLD The number of I/O buffers held by this vnode. FILEID The vnode fileid. In the case of ufs this is the inode number. IFLAG Miscellaneous filesystem specific state variables encoded thus: For ufs: L locked U update time (fs(5)) must be corrected A access time must be corrected W wanted by another process (L flag is on) C changed time must be corrected S shared lock applied E exclusive lock applied Z someone waiting for a lock M contains modifications R has a rename in progress For nfs: W waiting for I/O buffer flush to complete P I/O buffers being flushed M locally modified data exists E an earlier write failed X non-cacheable lease (nqnfs) O write lease (nqnfs) G lease was evicted (nqnfs) SIZ/RDEV Number of bytes in an ordinary file, or major and minor device of special file.
/vmunix namelist /dev/kmem default source of tables
Swap statistics are reported for all swap partitions compiled into the kernel, regardless of whether those partitions are being used. Does not understand NFS swap servers.
The pstat command appeared in 4.0BSD. 4th Berkeley Distribution May 13, 1994 4th Berkeley Distribution
Mac OS X 10.3 - Generated Sat Jun 7 16:37:24 CDT 2008