kextstat(8) BSD System Manager's Manual kextstat(8)
kextstat -- display status of loaded kernel extensions (kexts)
kextstat [-a] [-h] [-k] [-l] [-b identifier] ...
The kextstat utility displays the status of any kexts currently loaded in the kernel. The following information is shown for each loaded kext: Index The load index of the kext (used to track linkage references). Gaps in the list indicate kexts that have been unloaded. Refs The number of references to this kext by others. If nonzero, the kext cannot be unloaded. Address The address in kernel space where the kext has been loaded. Size The number of bytes of kernel memory that the kext occupies. If this is zero, the kext is a built-in part of the kernel that has a record as a kext for resolving dependencies among kexts. Wired The number of wired bytes of kernel memory that the kext occu- pies. Architecture (if the -a option is used) The architecture of the kext. Name The CFBundleIdentifier of the kext. (Version) The CFBundleVersion of the kext. <Linked Against> The index numbers of all other kexts that this kext has a ref- erence to.
These options are available: -a, -arch Print the architecture of the kext. -b identifier, -bundle-id identifier Display the status of only the kext with the given bundle iden- tifier. This option trumps the -no-kernel option; if both are given and a kernel component is specified, its information is shown. -h, -help Print a help message describing each option flag and exit with a success result, regardless of any other options on the com- mand line. -k, -no-kernel Don't show information for built-in components of the kernel. -l, -list-only Print the list of loaded kexts only and omit the header (useful for running output through text-analysis tools). -s, -sort Sort the list by load address.
The kextstat utility exits with a status of 0 on success and with a nonzero status if an error occurs.
kextcache(8), kextd(8), kextload(8), kextunload(8), kextutil(8) Darwin March 13, 2014 Darwin
Mac OS X 10.11.6 - Generated Sat Feb 4 09:45:19 CST 2017